Problems with Charge Amps Admin portal
Incident Report for Charge Amps
Resolved
This incident has been resolved.
Posted Jun 26, 2024 - 13:50 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 26, 2024 - 10:53 CEST
Update
We are continuing to work on a fix for this issue.
Posted Jun 25, 2024 - 13:36 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 25, 2024 - 13:33 CEST
This incident affected: Web Portals.